Check your setting in cellular data. If setting is off it will only use Wi-Fi